Avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

Avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): el programador no responde

hola. estoy haciendo un proyecto en el que estoy tratando de cargar el boceto en mi arduino NANO. he comprobado el cableado e incluso he tratado de cambiar mi cable USB varias veces, pero cada vez que traté de cargar el boceto en mi Arduino NANO estoy recibiendo el siguiente error:
Bien, nos hemos enfrentado a este problema cuando usamos el Arduino Nano. Esto ocurre con el Arduino Nano clonado en China que estás usando ahora mismo. El Arduino Nano clonado en China sigue usando el antiguo cargador de arranque del Arduino Nano, así que sigue las siguientes instrucciones para deshacerte de este error:
El error que se muestra durante la compilación y la carga se debe a la razón de que hasta ahora Arduino Nano está utilizando anteriores / viejos cargadores de arranque en él para programar. También me enfrenté a este problema en el inicio de la creación de algunos proyectos para una exposición de proyectos de educación STEM, me di cuenta de que todas las placas Arduino Nano que compré en la tienda local, acepta la versión antigua del cargador de arranque. Pero no hay que preocuparse por este problema. El Arduino Nano funciona bien y perfectamente utilizando este viejo cargador de arranque. Te recomiendo que consigas productos avanzados de SSLA junto con su soporte para utilizarlos. Aquí está el último producto lanzado por ellos es EFB-IoT, le sugiero que pruebe este también en sus proyectos.

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x65 ender 3

Hice todos los pasos y aún así no conseguí que se cargara el sketch. Sin embargo, si usaba windows 10 con el sketch de blink se cargaba bien. No sé si mi controlador USB está instalado incorrectamente para mi iMac corriendo Catalina. ¿Sabéis cuál es el driver para el sistema operativo de Mac? gracias
La verdad es que, aunque me manejo bien en Windows y Linux, no tengo mucha experiencia con macOS. Acabo de empezar a usar macOS por primera vez esta semana y la verdad es que me estoy peleando con las diferencias.
Mi entendimiento es que si usted está viendo un puerto aparecen y desaparecen cuando se conecta / desconecta la Uno, siguiendo las instrucciones en mi respuesta anterior, entonces esto indicaría que el controlador está bien.
El siguiente paso para depurar esto es subir un sketch a la Uno que devuelva los datos del puerto serie que escribas, luego conectar al Mac y ver si la conexión USB funciona. No tengo ni idea de qué controladores del adaptador USB vienen con Catalina, pero la conexión funciona bien con High Sierra.

avrdude stk500_getsync() programmer is not responding

I am not sure, but I think it is convenient, whenever you send something by Serial, to put a delay, I have seen in many codes that when they send a Serial Print, they put a delay and as a comment they put //for stability.
I have mounted the system in another PC with Windows 7 and I have the same problem. I have tried pressing reset while compiling and transferring with null results. I would appreciate any kind of help for beginner donkey with a high dose of neanderthal.
The most common is that we are using the pins Tx, Rx for another board, device, for example using those pins to feed a led etc, or we are using a GPS shield, BT, Eternet.,, Releasing those pins is solved (usually).

resp=0x20

Si nada de eso funciona, querrás intentar aislar el problema sustituyendo cosas: prueba con un ordenador diferente en el mismo arduino, prueba con un arduino diferente en el mismo ordenador, e intenta usar un cable USB diferente.
Por desgracia, también puede significar que has quemado tu microcontrolador. ¿Estabas haciendo algo peligroso justo antes de intentar cargar un nuevo sketch? ¿Sigue funcionando el microcontrolador, con su sketch previamente cargado?
Yo he tenido el mismo mensaje. Todas las veces se ha solucionado seleccionando el puerto correcto, es decir, USB, en el menú Herramientas y luego Puertos. Es un paso sencillo pero siempre se me olvida. Desconecto el Arduino para detener el programa actual, lo conecto de nuevo a mi ordenador para cargar el nuevo programa y obtengo el error, el pánico, la maldición, y sólo entonces, recuerdo.
En mi caso no había conectado el pin RTS del chip FTDI a un condensador que iba al pin RST del Arduino Pro Mini. Una vez que instalé esta conexión, ya no me dio el error y pude cargar el código.
Tenía exactamente el mismo problema. Probé a instalar el IDE en otro portátil y subí el programa desde ese portátil. Problema resuelto. Entonces volví a mi portátil, desinstalé el IDE y lo volví a instalar… empezó a funcionar.

Usamos cookies para asegurar que le damos la mejor experiencia en nuestra web. Si continúa usando este sitio, asumiremos que está de acuerdo con ello. Nuestros socios (incluye a Google) podrán compartir, almacenar y gestionar sus datos para ofrecerle anuncios personalizados    Más información
Privacidad